Ayuda para el pHoenix ; creada por lion ©2004

Página de inicio
El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Ayuda para el pHoenix ; creada por lion ©2004

Bienvenidos a vuestro tutorial

Espero de todo corazón que os encontreis a gusto navegando por este tutorial y que al menos sea del agrado de la mayoria

Si entrais en [image] emulespaña , encontrareis el foro del [image] mod Phoenix; pero para los que nunca hayan entrado en emulespana [image] aqui os dejo el enlace para que os podais registrar.
Tanto para los que lo hagan por primera vez , como los que no ; por favor postear vuestras dudas en el sitio adecuado , Esto facilitara enormemente las cosas y los primeros beneficiados vais a ser vosotros seguro que se os contesta mas rápido y obtenéis mas respuestas a vuestras preguntas.
Si hacéis capturas de pantalla no ponerle tanta resolución aligerarlas un poco muchos usuarios con conexiones de velocidad baja seguro que os lo agradecerán enormemente; (acordaros que incluso muchos de vosotros empezasteis con un moden de 56k y lo mal que lo pasabais cuando no podíais cargar la pagina y al final desistíais y posiblemente no volvíais a entrar mas).
Si tenéis alguna duda de donde postear no lo hagáis en los hilos fijos; siempre podéis iniciar una nueva discusión.

Si quereis dejar vuestras sugerencias para el mod pHoenix lo podeis hacer [image] aqui ; si quereis comentar algún fallo que os pueda dar , lo podeis hacer [image] aqui; si quereis dejar vuestra configuración o mirar la de algún otro usuario ; por si os puede valer a vosotros , lo podeis hacer [image] aqui ; en cambio si quereis dejar vuestros comentarios sobre la versión con kadmelia , lo podeis hacer [image] aqui; ¿y sin la red kadmelia? , por supuesto que también la hay (aunque el futuro será con las dos redes) [image] aqui .

Otra cosa también importantísima es que con demasiada frecuencia se suelen preguntar cosas que ya han sido contestadas anteriormente, así que por favor usar antes la búsqueda y sobre todo no estaría de mas visitar este foro de vez en cuando [image] Preguntas frecuentes sobre el emule; un foro genialmente hecho por black al cual aprovecho para darle las gracias por su trabajo.

Aparte de todas estas cositas , también os recomiendo que os paseis por este foro sobre [image] seguridad ; puede que en el encontreis también posibles respuestas o soluciones a vuestro mal de la mula (si ese fuera el caso) , lo encontrareis en [image] Software general y Aplicaciones

(Muchas cosas de las que voy a poner ya han sido publicadas , espero que este intento de intentar agrupar la grán mayoria os ayude en el buén funcionamiento del mod)

The pHoenix team Intentaré ir poniendo poco a poco , los temas mas interesantes , recomendaciones , aclaraciones , etc etc

hacia arriba

Mostrando las páginas indice y contenido

Páginas indice del tutorial
El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Páginas contenido del tutorial
Significado de iconos
Carpetas y archivos del mod pHoenix

hacia arriba


HTMLHelp File Created Using:

Web2HTMLHelp 		Free To Download From:
http://www.web2htmlhelp.co.uk

Also Available:
HTMLHelp ePublisher
HTMLHelp eDocument Creation Made Easy

Free To Download From:
http://www.htmlhelp-epublisher.co.uk

[ Back ]


Configuraciones

El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Configuraciones

TUTORIAL PHOENIX PARA MÓDEN 56K

Por Lion y Pazäku ó Pazäku y Lion ;)
Tanto monta , monta tanto isabel como fernando ; (esto ultimo para evitar bromas y malos pensamientos es un dicho muy antiguo...desde los reyes catolicos)

<<<PESTAÑA SERVIDORES>>>>>>

En la pestaña servidores elegir los que mayor capacidad de usuarios tengan y el que menos ping dé Hacerlos fijos (botón derecho sobre el servidor y "Añadir a la lista de servidores fijos").
A menos ping del servidor hará las gestiones entre el ordenador y los servidores mucho más rápido y por consiguiente encontrará fuentes más rápidamente. Quizás con ADSL no se noté mucho pero con módem 56k sí. En alguna ocasión quedan las fuentes en rojo y todo el tiempo en estado "conectando" al mirar el servidor casi siempre da un ping muy alto. En ese caso es mejor conectarse a otro que tenga un ping inferior a 1000. Para organizarlos se hace click en "Ping" y los ordena. Este valor cambiará a lo largo del tiempo debido a varios factores.

<<<PESTAÑA TRÁFICO>>>>>>

Destacar dos funciones (botón derecho sobre el archivo).
. Fuentes máximas. Esta opción sirve para poner un límite máximo de fuentes a cada archivo en particular. Por ejemplo: Tenemos 3 archivos bajando y en "Máximo fuentes por archivo en Conexiones", con carácter general, hemos puesto 200 pero nos interesa más un archivo que otro. En ese caso le ponemos 225 a uno, 150 a otro y al tercero 25. De esta forma cómo máximo encontrará 400 fuentes y no 600 cómo seria lo normal, así ahorramos fuentes y tendremos menos overhead.
Esto es especialmente útil y altamente recomendable sobre todo cuando tenemos archivos con muy pocas fuentes; se ahorra mucho gasto inútil, pretendiendo que nuestro pHoenix encuentre un número determinado de fuentes cuando en realidad no existen.

. Establecer prioridad lineal.- Especifica el orden de descarga de los archivos. En la pestaña LP podemos visualizar el orden. El que más nos interese bajar 1, el siguiente 2 y así sucesivamente.
<<<PESTAÑA COMPARTIDOS>>>>>>

Esta pestaña puede ser muy útil para ver los archivos más solicitados y los que lo son menos. Hay que fijarse principalmente en las peticiones al archivo, que serán los más solicitados.
No aconsejo tener muchos archivos compartidos para módem 56k. Se formarán colas enormes y nadie conseguirá bajar completo un archivo. Es mejor compartirlos inteligentemente, dejar más tiempo compartido los que menos fuentes tengan y clasificarlos en carpetas. Por ejemplo: música, juegos, aplicaciones, etc... y compartir una semana cada carpeta. De esta forma nos aseguramos de compartir pero no entorpecer nuestras descargas. En preferencias> directorio> vais a vuestro incomig y elegís las carpetas que queréis compartir en ese momento.
Hay que tener en cuenta también que el gráfico de "Partes obtenidas" está muy bien pero consume más recursos.
<<<PESTAÑA PREFERENCIAS>>>>>>

Algunas ventanas las omitiré porque son obvias o porque son a gusto de cada usuario :).

MOSTRAR

-> Estilo barra de progreso- En 3D el gasto de recursos es mayor.
-> Conservar uso de CPU y memoria.- Para equipos antiguos marcar todas las opciones. Yo tengo activadas todas excepto la segunda.
-> Autocompletar (función registro).- Activado

CONEXIÓN

Capacidad: Descarga: 7. Subida: 3. O dejar por defecto esto no influye para nada es sólo para la capacidad de las gráficas.
Límites: Descarga: 6 (Bajar si se navega. Para navegar bien poner 5). Subida: 2.1 (como máximo 2.3)
Puerto: Cambiar los puertos puede mejorar la velocidad. Sobretodo es recomendable cambiar el puerto TCP, podéis añadirle un 1 a los que vienen por defecto.
Max fuentes /archivo: W98 y WME máximo 100. Para XP máximo 280. La suma de todas las fuentes de todos los archivos no deben superar las 500 ó 600 fuentes para XP; para W98 -WMe no deben pasar de 300 ó 400 como mucho.
Límites de conexión: W98 y WME menos de 50. XP máximo 150. Cuanto mayor sea este valor, más overhead generará, pero a su vez contactareis con más fuentes y la probabilidad de encontrar una fuente de la que descargar aumenta, aunque la velocidad será menor. Para W98 y WMe 40 ó 45 y para XP 100 ó 125 está bien, aunque podéis jugar con estas opciones según vuestras preferencias en ese momento.
Red: En equipos modernos y XP funciona bien la red kad. En equipos antiguos y con W98 o WME si os va lento desactivar la red kad.
Auto conectar al iniciar.- Activado
Reconectar al perder la conexión.- Activado. Opción muy buena en XP si, además, tenéis activado en Panel de Control> Conexiones de red>"vuestra conexión">Propiedades>Volver a marcar si se interrumpe la línea. En caso de que perdáis la conexión a Internet y no estéis presentes delante del ordenador, este se reconectará automáticamente y el emule, al no cerrarse, volverá a conectarse el solito a un servidor :)
Mostrar ancho de banda excedente.- Desactivado

SERVIDOR. Todas las opciones activadas excepto "Actualizar lista de servidores al conectar con un cliente". En "editar" servidores es conveniente tener más de uno por si alguno falla en algún momento tener otro al que recurrir. "Auto conectar a servidores fijos" es cuestión de gustos yo suelo tener buenos servidores en fijos y por eso prefiero este sistema.

ARCHIVOS
Opciones marcadas:
-> Ver mis compartidos= nadie
-> Activar I.C.H.
-> "Añadir nuevos archivos compartidos con auto prioridad", "Añadir nuevas descargas con auto prioridad","Limpiar nombre de archivo".
-> "Intentar transferir partes completas en todas las subidas", "Buscar en el portapapeles enlaces ED2k"
CONFIGURAR ESTADÍSTICAS. Para haceros una idea visual de vuestras descargas es mejor poner un intervalo de tiempo más amplio que el que viene por defecto. Por ejemplo: intervalo de actualización: 50seg, tiempo promedio de grafico: 5 minutos, esto en la gráfica equivale a 6:08 horas. Si no os interesa ver la gráfica o estáis escasos de recursos también la podéis poner a 0 (desactivada).

OPCIONES ADICIONALES
-> Tamaño del buffer por archivo: 234kb (por defecto)
-> Tamaño cola de espera: 2.000 (mínimo)
-> Nuevas conexiones máx./ 5 seg: Equipos poco potentes 15 ó 20. Resto 20 ó 25 cuanto más subáis este valor más overheard generará.
-> Capturar Automát. Enlaces ED2k....-Marcar
-> Usar Sistema de Créditos.....-Marcar
-> Filtrar IP de servidores y clientes LAN.- Marcar
-> Mostrar más controles..... Marcar si eres curios@, sino no es necesario.
-> Comprobar espacio en disco. - Con esta opción marcada el emule comprueba el espacio en disco cuando añades un enlace, sino lo tienes no te dejará bajar el archivo hasta que lo soluciones. Se puede poner el espacio mínimo libre que se quiera.
-> Nombre PC para enlaces eD2k propios: Para identificar mejor archivos propios en la red emule.
-> Guardar a disco.- Marcada
-> Información extra.- Sólo para curios@s
-> Grabación segura de archivos met./.dat.- Marcar al apagar.
-> Intervalo actualiz. Conexión a Servidor: 15
PHOENIX ONE:

Conexiones:
-> Aplicar límites a datos + ancho de banda excedente--->Si lo activas sube los limites de descarga / subida a 6,9 / 2,3.Y sino lo activas deja los limites en 6 / 2,1
-> MTU ---> [image] www.speedguide.net. Con carácter general, en Windows XP/2000 el MTU=1500 y en 98/Me dejarlo por defecto o como indique la página anterior.
-> Tamaño del buffer del socket de envío ---> 8192 (por defecto)
-> Inicio rápido ---> Desactivado. Si lo activáis buscará fuentes muy rápido al iniciar pero seguro que se colgará el ordenador por la sobrecarga.
-> Manejar conexiones ---> Desactivado

Subidas:
-> Controlar slots de subida con NAFC ---> Desactivado. Si quieres activarlo limitalo a la misma velocidad que tengas puesto en la subida (2,3 si tienes activado "Aplicar límites a datos + ancho de banda excedente" ó 2,1 si lo tienes desactivado)
-> Puestos mínimos de subida ---> 2
-> Ajustes de subida:
. Sistema de subida rígido.- Desactivado
. Focalizar ancho de banda en un slot.- Activado
. Minimizar slots .-Activado

Servidor:
-> Desactivar intercambio de fuentes entre clientes.- Desactivado.
-> No repreguntar fuentes después de un cambio de LowID/Hig. Activado.

Backup:
Para hacer copias de seguridad de los archivos importantes de la mula.
-> Autobackup y doble backup.- Activado.

Filtro de Mensajes:
Si tenéis la respuesta de programa activada marcar lo que os apetezca, sino desmarcados todos.

Seguridad:
-> Anticorrupción.- Marcarlo todo.
-> Control avanzado antileechers.- Marcarlo todo :)
PHOENIX RELOAD

Categorías:
A gusto de cada uno.
Configurar estadísticas:
Por defecto.

Míniemele:
Activarlo consume más recursos.

Visualización:
A gusto de cada uno :). "Alto contraste" es para las personas que tengan alguna deficiencia visual.
-> Modo invisible.- Si usáis el emule en la oficina puede ser muy útil para esconder el emule de miradas indiscretas ;)

Archivos:
-> Número de partes compartidas antes de....- 5 (por defecto)
-> Marcalo todo.

Opciones varias:
-> Prioridad:
Es la prioridad que le dais al emule con respecto a otros programas que estés utilizando en ese momento. Es decir si sólo utilizáis emule y queréis que éste tenga más prioridad pues "alta", si utilizáis otros programas al mismo tiempo y no necesitáis bajar rápido "baja". Recomendación "normal".
-> Sistema de créditos. A gusto de cada uno. Yo uso Pawcio.Con la multicola da muy buenos resultados
-> Mostrar SpreadBars.- Activado.

SUGERENCIAS
>>> Para ordenadores poco potentes o para aquellos que no quieran muchas funcionalidades sino lo más básico, subir y bajar, está el Baby Phoenix ;).

>>> Archivos normalmente descargando 3 ó 4, más si son pequeños y tienen pocas fuentes.

>>> Tener actualizado el servet.met.

>>> Actualizar driver del módem, preferiblemente de su página oficial.

>>> Todo depende de muchos factores.....y cada ordenador es un mundo...Pero principalmente lo más importante es la: P A C I E N C I A.

>>> Para dudas, consultas, sugerencias etc.... podeis hacerlo en el hilo [image] Encontremos el MOD para modem 56k ; lo encontrareis en [image] emulespaña
; también podeis consultar y resolver cualquier duda , o incluso ayudar en el subforo [image] pHoenix


Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Aclaración sobre distintos conceptos

Conceptos varios

MSS (tamaño máximo del segmento) define el segmento más grande de los datos del TCP (protocolo del control de la transferencia) que el Winsock está preparado para recibir. Cuando se establece una conexión, los dos extremos acuerdan utilizar el más pequeño del valor de cada extremo. 40 octetos, MSS es generalmente 40 menos que el MTU (Maximum Transmission Unit).

Cuando una conexión TCP se establece, el sender (el que envía) y el request (el que recibe) negocian el tamaño máximo de un segmento de datos que aceptan ambos host. Este valor, llamado Tamaño máximo de Segmento (MSS) es diferente del MTU porque solo toma el tamaño máximo del segmento de datos de
una porción del paquete, y no incluye el encabezado. Si cada segmento, con el encabezado, no excede el MTU mas pequeño cuando es enviado a su destino, entonces no será fragmentado. Entonces, ya que el tamaño de un encabezado TCP es de 40 bytes, el MSS es calculado como MTU menos 40. El valor MSS es
provechoso para determinar el tamaño del RWIN, que es el número máximo de
bytes de datos que pueden ser retenidos, pendiente el recipiente de la llegada del paquete de aceptación del sender. Comúnmente, el valor RWIN debe ser un múltiplo de 2-10 veces el valor MSS.

Lamentablemente, la mayoría de los usuarios se conectan a Internet desde casa o desde el trabajo mediante un módem común y analógico y no a través de LAN. Para los ajustes MTU y MSS de Windows 95 , 98 son completamente INADECUADOS y en realidad impiden el rendimiento óptimo del sistema. Hablando en términos técnicos esto es porque los datos son enviados a Internet en porciones llamadas PAQUETES cada uno de los cuales tiene una dimensión de 576 bytes. Esta dimensión es lo que se conoce como Unidad Máxima de Transmisión (MTU) de Internet.
El ajuste MTU de Windows 95 es, sin embargo, de 1.500 bytes, muy lógico si hablamos de redes LAN, que transmiten en paquetes de 1.500 bytes. Pero si estamos conectados a Internet a través de un MODEM, recibimos paquetes de 576 y no de 1.500 bytes. Así el tiempo de transferencia SE ALARGA al tener que reenviar los paquetes de datos constantemente para reajustar su tamaño. Esto explica por qué, durante la transferencia de un fichero desde Internet, las luces del módem pestañean en lugar de estar siempre encendidas.

Los parámetros que se indican controlan las propiedades de la comunicación TCP/IP; el MTU (Maximum Transmission Unit) o tamaño de paquete de una red, es la máxima cantidad de datos que pueden ser transmitidos en un sólo frame de esa red. Cambiando estos valores se puede conseguir un aumento en las transferencias por Internet. El valor MTU esta representado en Windows 98 como IPMTU y puede localizarse en el registro (se accede a él con regedit.exe) en HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\Ndi\params\IPMTU\enum. existen varios valores definidos: Automático, Medio, Grande y Pequeño. Estos hacen referencia a la opción que se encuentra en el panel de control en Red->Adaptador de acceso telefónico->Avanzado->Tamaño del Paquete IP. Para poder cambiarlo debemos elegir tamaño Pequeño en el panel de control y modificar el valor correspondiente en el registro. De todas formas, no es conveniente jugar mucho con el registro (al ser una de las partes más críticas del sistema), y existen diversas utilidades que permiten realizar esto de manera segura. Uno completo es Tweakmaster . Con el podemos alterar todos los parámetros del protocolo TCP/IP con el fin de acelerar nuestra conexión a Internet

Uno de los problemas que presenta la conexión a Internet a través del Acceso Telefónico a Redes en Windows, sobre todo si se hace por medio de una línea telefónica conmutada, es su lentitud, desesperante a veces. Son múltiples los factores que inciden en la velocidad de esta conexión: limpieza (sin ruidos) de la línea, saturación de la misma, características del módem... y, algo que muchos desconocen, adecuados valores para ciertas variables en el sistema operativo.

En Windows 95/98, las variables que regulan la conexión de nuestro equipo con la Red son las siguientes:

MTU (Maximum Transmision Unit): Indica el máximo número de datos que pueden ser transferidos en cada paquete de transmisión.

MSS (Maximum Segment Size): Es el máximo tamaño que puede tener el segmento de TCP en una conexión particular. Su valor es igual al de MTU - 40.

RWIN (Receive Window): Determina la cantidad de datos que puede recibir nuestro ordenador. Suele ser el valor de MSS multiplicado por 3 o por 4.

TTL (Time To Live): Indica el número de hops (saltos) que produce cada sistema en la Red. El valor por defecto en Windows 95/98 es 32.

NDI Cachesize: Es una opción de la que Microsoft no incluye información. Está habilitado en Windows 95/98 pero deshabilitado en Windows NT. El valor por defecto es 0, aunque puede tomar valores de 0, 16, 32 o 64, teniendo en cuenta los valores de MTU y RWIN.

Podemos cambiar directamente los valores anteriores en el registro de Windows. Este sistema sería muy rudimentario para conseguir una conexión aceptable, ya que tendríamos que jugar con números, a veces no apropiados, y probar lo que ocurre, después de reinicializar el ordenador, al conectarnos a Internet.
un poco mas arriba ya está puesto como se accede al registro , programas y utilidades si después de esto veis útil cambiar el mss y no quieres toquetear el registro pues el que te la pagina puede servir
cuidado con toquetear el registro no hacerlo si no sabéis el que ponga como hacerlo no quiere decir que os lo recomiende sin copia de seguridad ni que me haga responsable así que ojito al dato

Hay una serie de programas que hacen copias de seguridad sin riesgo alguno y además son GRATUITOS.algo que deberíais hacer con no poca frecuencia.

GLOSARIO DE TÉRMINOS DE ADSL E INTERNET.

ACS

(Access Control List). Es una tabla que le dice a un sistema los derechos de acceso que cada usuario posee para un objeto determinado, como directorios, ficheros, puertos, etc. Técnicas para limitar el acceso a los recursos según la información de autenticidad y las normas de acceso.

ADSL

(Asymetric Digital Subscriber Line). Este sistema permite transmitir información en formato digital a través de las líneas normales de teléfono.

Ancho de Banda

Número máximo de datos que pueden circular por un camino (línea ADSL) en un tiempo determinado (segundos)

ATM

(Asynchronous Transfer Mode). Protocolo orientado a conexiones de alta velocidad para el transporte de varios tipos de tráfico a través de una red. ATM empaqueta los datos en una celda de 53 bytes de longitud fija que se puede intercambiar rápidamente entre conexiones lógicas de una red. El modo de transferencia asíncrona se llama también ATM.

Banda Ancha

Característica de cualquier red que permite la conexión de varias redes en un único cable. Para evitar las interferencias en la información manejada en cada red, se utilizan diferentes frecuencias para cada una de ellas. La banda ancha hace referencia también a una gran velocidad de transmisión.

Binario

Se dice que un sistema es binario cuando sólo caben dos posibles resultados o respuestas a un planteamiento determinado. El código binario es la base de la informática, al reducir todas las posibles instrucciones interpretadas por la máquina a un código de unos y ceros (encendido/apagado; si/no) por el que el microprocesador funciona y ejecuta las órdenes introducidas en él.

BIOS

(Basic Input Output System) Pequeño programa que coordina las actividades de los distintos componentes de un ordenador y comprueba su estado. El término se refiere, por lo general, al ROM BIOS en un computador personal, que contiene ciertas partes del sistema operativo.

Bug

Error en la codificación de un programa que provoca inconvenientes diversos al usuario.

Cookie

(galleta) Cuando se visita una página Web, es posible recibir una Cookie. Este es el nombre que se da a un pequeño archivo de texto, que queda almacenado en el disco duro del ordenador. Este archivo sirve para identificar al usuario cuando se conecta de nuevo a dicha página Web.

Dirección IP (dirección de protocolo de Internet). La forma estándar de identificar un equipo que está conectado a Internet, de forma similar a como un número de teléfono es único dentro de una red telefónica. La dirección IP consta de cuatro números separados por puntos y cada numero es menor de 256; por ejemplo 192.200.44.69. El administrador del servidor Web o su proveedor de servicios de Internet asignará una dirección IP a su equipo.

DNS

Es el acrónimo de Domain Name Server (servidor de nombres de dominio). Un servidor de nombres de dominio es un servidor ubicado en Internet que traduce las URLs (Uniform Resource Locator o localizador uniforme de fuentes) como www.adslayuda.com en direcciones IPs. Muchos ISPs no necesitan que se introduzca esta información en el router. Si está usted utilizando un tipo de conexión de IP estática, entonces puede necesitar introducir una dirección de DNS y una dirección de DNS secundaria específicas para que su conexión funcione adecuadamente. Si su tipo de conexión es dinámica o PPPoE, es muy probable que no necesite introducir una dirección de DNS.

P2P

(peer-to-peer sharing). Compartición de igual a igual.

PLC

(PowerLine Comunications) Tecnología de comunicaciones por medio del cable eléctrico, permite conectar a internet a través de cualquier enchufe por medio de un modem plc.

Proxy

Es un programa que realiza la tarea de encaminador, utilizado en redes locales, su función es similar a la de un router.

Router

Enrutador. Originalmente, se identificaba con el término gateway, sobre todo en referencia a la red Internet. En general, debe considerarse como el elemento responsable de discernir cuál es el camino más adecuado para la transmisión de mensajes en una red compleja que está soportando un tráfico intenso de datos.

TCP

(Transmission Control Protocol). El protocolo TCP proporciona un servicio de comunicación que forma un circuito, es decir, que el flujo de datos entre el origen y el destino parece que sea continuo. TCP proporciona un circuito virtual el cual es llamado una conexión. Al contrario que los programas que utilizan UDP, los que utilizan el TCP tienen un servicio de conexión entre los programas llamados y los que llaman, chequeo de errores, control de flujo y capacidad de interrupción.

TCP/IP.

(Transmission Control Protocol over Internet Protocol) Protocolo de Control de Transmisión sobre Protocolo de Internet. Éste es el protocolo estándar para la transmisión de datos por Internet. Proporciona comunicación entre redes interconectadas formadas por equipos con distintas arquitecturas de hardware y distintos sistemas operativos.

UDP

El protocolo UDP (User Datagram Protocol) proporciona aplicaciones con un tipo de servicio de datagramas orientado a transacciones. El servicio es muy parecido al protocolo IP, pero varía en el sentido de que no es fiable y no esta orientado a la conexión. El UDP es simple, eficiente e ideal para aplicaciones como el TFTP y el DNS.

¿Que es el NAFC?

NAFC - Network Adapter Feedback Control

Esta información está sacada de un post de maella y traducido por ikabot

INTRODUCCION:

Todas las aplicaciones que necesitan regular su ancho de banda de subida tienen el mismo problema.
Cuando se le pide al sistema operativo (SO) que envie datos a otro cliente remoto, pueden ocurrir
tres cosas diferentes.
-- El envio se podría producir inmediatamente
-- El envio podría ser retrasado por el SO (por ejemplo: el cliente remoto no esta preparado, se
ha alcanzado el limite de la capacidad de la red...)
-- El envio no se puede realizar (por ejemplo: se pierde la conexión con el cliente remoto)

Otro problema es que a parte del trafico del usuario, en la red tenemos trafico generado por el propio protocolo. Normalmente cuando se recibe datos de un cliente remoto, el sistema operativo debe enviar algunos paquetes de reconocimiento (ACKs) para comunicar al cliente remoto que se ha recibido los datos correctamente. Estos paquetes de reconocimiento o ACKs incrementaran la carga del tráfico en la red. El protocolo crea un exceso de ancho de banda (overhead) que una aplicación no puede controlar totalmente.

Además de todo esto, está el tráfico generado por otras aplicaciones para sus propósitos (por ejemplo: navegador, bittorrent, ftp,...)

En resumen: Cuando una aplicación trata de regular su trafico, ella sabe lo que está tratando de enviar pero no sabe exactamente cuando se envía ni que se envía.

SOLUCION IDEAL:

En el caso de Emule, la solución ideal sería conocer en tiempo real el nivel de trafico cursado a través del MODEM en un instante (por ejemplo: 56k, ADSL,...). Si una aplicación tuviera acceso a esta información, sería muy fácil regular el ancho de banda. Hay que tener en mente que el objetivo es usar todo el tiempo el 100% de la capacidad de nuestra conexión. Nada más, nada menos. Pero desafortunadamente, no hay forma de obtener esta información directamente del MODEM.

SOLUCIONES ACTUALES:

Hay diferentes intentos de resolver este problema. Una lista de alguno de ellos.

1. Uso inferior de la capacidad de la red para asegurarnos suficiente ancho de banda para
el tráfico generado por el protocolo. Un ejemplo de esto es el viejo EMULE (EMULE 0.10x - 0.30e)
Desventaja: No se usa todo el ancho de banda

2. Tratar de enviar periódicamente paquetes (ping) con el propósito de medir el tiempo de reacción del MODEM. Así, si el tiempo de reacción crece mucho, esto nos indicaría un comienzo de saturación del MODEM. Un ejemplo de esa solución es el USS introducido por ZZ y que en un principio tomaron mods como morph, the black hand,...y que actualmente también ha introducido el Emule oficial en sus nuevas versiones con el protocolo kadmelia También el mod de Pawcio y sus derivados (Stormit, Roman2K, Mortillo,...) han tomado esta solución pero no usa el mismo código de ZZ sino una variante de Pawcio
Desventajas:
- Añade trafico excedente al trafico
- Tiempo de reacción limitado > 1s
- Precisión media

3. Tratar de medir el tiempo de reacción de los clientes remotos. Un ejemplo de esta solución
sería el viejo SUC que introdujo Lovelace hace tiempo.
Ventaja: No trafico excedente
Desventaja:
- Tiempo de reacción limitado > 1s
- Precisión Media
- Depende de la capacidad del MODEM local y remoto.

4. Medir el tráfico al nivel del adaptador de red (tarjeta ethernet) y no al nivel del MODEM.
Si todo el tráfico es intercambiando con el MODEM, entonces el adaptador de red tendrá una imagen
1 a 1 del tráfico del MODEM. Esta solución fue la adquirida en su momento por Maella y que mods como Xtreme y pHoenix son sus únicos herederos.

Ventajas:
- No trafico excedente
- Tiempo de reacción muy rápido < 100ms
- Muy preciso
Desventajas:
- No esta disponible en todos los sistemas operativos (win95 por ejemplo)
- Puede requerir la actuación del administrador
- Mide todo el trafico enviado o recibido por nuestro PC en la red, es decir, si
estuviéramos en una red local, también mediría el trafico con los computadores
de la red local.

5. Usar el "Layered Service Provider" de Windows...Solución no tomada por nadie (aun) en Emule.

EN RESUMEN:

El NAFC es la mejor solución, pero solo si el adaptador de red es usado únicamente para intercambiar trafico con el MODEM.

Sobre el MSS ; MTU ; ETC A ver si conseguimos despejar algunas dudas.


Buscar

El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Aclaración sobre distintos conceptos

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Ayuda para el pHoenix ; creada por lion ©2004


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Buscar

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Carpetas y archivos del mod pHoenix


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

El equipo

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Para módem 56K

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Significado de iconos


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Todo sobre el mod pHoenix

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Buscar

Busqueda en este tutorial

¿Buscais algo determinado? ; pués aquí podeis buscar por todo el tutorial ; solo teneis que hacer clik en la inicial del concepto buscado y después en el elemento que deseeis de entre los resultados de la búsqueda.

hacia arriba

Búsqueda en este tutorial por páginas indice

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

Un poco de historia

hacia arriba

Búsqueda en este tutorial por páginas contenido

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 0-9

No se ha encontrado ninguna entrada


Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Diferentes consejos y recomendaciones

Consejos y recomendaciones varias

Mucho se escribe y pregunta sobre ; ¿Cuántas fuentes por archivo debo poner? ; ¿Cuántos archivos debo poner a descargar? Y así etc., etc.
Y para estas cuestiones solo hay una máxima , que es que el número total de fuentes no supere las 3000 ó 3500.

Si ponéis muchos archivos a descargar, tardareis mas en completarlos y si son pocos lo haréis antes; si os preguntáis; ¿entonces que hago? No os voy a decir una configuración mágica e infalible pero si os puedo decir que no hace falta llegar al máximo aconsejable.
Un ejemplo seria sobre todo para aquellos ordenadores que anden un poco escasos de recursos:600 fuentes por archivo y cuatro a descargar ; lo que os daría un numero máximo total de fuentes encontradas 2400 fuentes , esto siempre que los archivos en cuestión estén con fuentes suficientes ; si queréis hacer una descarga tan pronto se pone a distribuir el archivo posiblemente no andará muy rápido , todo lo contrario a que si el archivo que os queréis bajar lleva dos meses distribuyéndose (lo de los dos meses es a modo de ejemplo) ; pero si se dan estas circunstancias ….de que el archivo está bien distribuido para no dejar el ejemplo ; 600 fuentes son mas que suficientes para que vuestra descarga vaya por buen camino y esto es valido sobre todo para los ordenadores que no se deban de exprimir demasiado y con las 2400 fuentes totales no debería de andar demasiado ahogado o incluso tres archivos en descarga con 800 fuentes por archivo lo que nos daría de igual manera las 2400 fuentes totales y siempre nos quedaría (al menos en teoría) un margen en el ordenador para poder pedirle trabajar con otra aplicación (dependiendo de cual , puesto que un juego por ejemplo nos comería demasiados recurso y posiblemente habría que cambiar la configuración de vuestro emule).

Conclusión:

De vosotros depende si queréis descargar antes los archivos poniendo pocos a descargar al mismo tiempo o si por el contrario preferís poner mas y tardar un poco mas ; solo recordar que no es necesario un numero determinado de archivos a descargar , ni tampoco es necesario alcanzar el numero de fuentes máximas aconsejables ; aunque por otra parte para cualquier ordenador de los de hoy en día con 8 archivos en descarga y 400 fuentes por archivo no tendréis problema ; otro ejemplo… 600 fuentes por archivo y 5 archivos totales en descarga y otro mas: 800 fuentes por archivo y 4 archivos en descarga .

Pués espero haberos aclarado vuestras dudas si las teníais, ejemplos os puse para ello

PROBLEMAS CON EL ANTIVIRUS NOD32 Y EL EMULE por hat:

Es necesario actualizar el nod32, no solo las bases de virus, sino los componentes del programa a la versión 2.008 del soporte para Internet (podéis mirar la versión que tenéis del componente en cuestión desde "registros del sistema"-"información" dentro del menú del nod32.
Una vez que os aseguréis de que tenéis la última versión de los componentes del nod32 tenéis que excluir del módulo AMON la carpeta del emule
y del módulo IMON (si tenis una versión antigua del nod32 no podéis hacer exclusiones para este módulo) excluir del análisis al emule.exe.

Alegrar esa cara Y no golpeis el ordenador que el no tiene la culpa.


Distintas cuestiones sobre los servidores
Un poco de historia
Todo sobre el mod pHoenix
Para módem 56K

Distintas cuestiones sobre los servidores

Connection refused. Your IP is currently blacklist

¿asusta?...; pues tanquilos que no pasa nada os voy a explicar el porqué de este mensaje y lo que significa:
Tranquilos que no estáis en ninguna lista negra, este mensaje aparece con las nuevas versiones que han salido de servidores (los Lugdunum v.75 y posterior)Lo que tienen estas nuevas versiones que ahora te avisan cuando eres baneado y antes no.
Cada IP tiene 1200 créditos Cada petición enviada al servidor consume un cierto número de créditos.
Por lo menos 1 crédito por cada fichero + una cantidad variable:
* Una petición de conexión consume 100 créditos * Una petición de fuentes para un fichero que estás descargando cuesta 16 créditos.
Si la cantidad de créditos que tienes llega a cero (o menos): BLACKLIST para esa IP durante un periodo variable de tiempo, que se configura en el servidor.
Si durante el tiempo de baneo, tu cliente sigue intentando conectarse al servidor, el servidor extiende el período de bloqueo.
El crédito vuelve a crecer al ritmo de una unidad por segundo.
Si descargas muchos ficheros (+ de 50) es bastante probable que dejes tu crédito a 0, por que 50*17 = 850 + el crédito por conectarte al servidor (100) = 950
A si que ya sabeis el porqué de este aviso ; o sea que no empeñaros en intentar entrar en un servidor solo por qué tengais el habito de hacerlo , tener cuidado , o si no incrementareis el tiempo de baneo.

Otro mensaje que nos pueden dar ; es el que es imposible crear socket en el puerto 4662

Una causa posible a este error puede ser que otra aplicación está usando dicho puerto 4662 (es el que viene por defecto en la mula)

Error: Tu puerto 4662 (o el que tengais puesto) no esta disponible. Esto nos va a provocar una id baja (lowid)

En este caso teneis algo que os esta bloqueando el puerto ; posiblemente un firewall (cortafuegos) , un router mal configurado etc. Para configurar vuestro router o módem aqui os dejo varios modelos para que aprendais a configurarlos (como este manual va a estar en continuo crecimiento , si no veis el vuestro podeis avisar para que se incorpore a este tutorial para el mod phoenix)

Error fatal intentando la conexión. La conexión a Internet podría estar desactivada.

Poco se puede explicar , creo que está bién claro el porqué de este aviso ; pero ojo que no tiene porqué ser necesariamente que no tengais conexión a internet ; las causas pueden ser varias entre las que se incluyen:
Que tengais el zone alarm (este firewall parece que no se lleva bién con el emule , aunque como ocurre con todos , solo necesita una buena configuración) ; que tengais vuestra conexión ocupada etc.

El cliente 'xxx' (IP:xxx.xxx.xxx.xxx) ha ocasionado un error: hashset recibido corrupto o inválido. Desconectando cliente!

Esto ha sido provocado por otro cliente que os envió un hashset inválido al pedir una fuente ; nada se puede hacer en este caso.


Significado de iconos

El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Significado de iconos

Significado de iconos

Lo que significa cada icono Su significado etc.

hacia arriba

 | En cola o preguntando a este cliente.
 | Transfiriendo o recibiendo el hash de este cliente.
 | Conectando a este cliente.
 | No se necesitan partes ó bién no se puede conectar a causa de un bajo id
 | Estado desconocido
 | Teneis un nuevo mensaje
 | El archivo en descarga dispone de un comentario positivo
 | Archivo considerado corrupto ó fake no valido . De todas formas si veeis esto antes de borrar el archivo comprobar vosotros mismos que verdaderamente está corrupto ó es un fake ; sobre todo si habeis cogido el enlace para la descarga de un sitio de confianza.
 | Estais conectados con id alta
 | Conectado con id baja
 | Icono de Sistema eMule cuando está conectado a un servidor con un ID bajo.
 | No está conectado a un servidor
 | Conectado a un servidor
Todavia falta la descripción de alguno mas , pero los iré poniendo en sucesivas entregas |


Carpetas y archivos del mod pHoenix

El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Carpetas y archivos del mod pHoenix

Carpetas del mod pHoenix

Y sus archivos que se guardan en su interior Sus respectivos archivos que se guardan en su interior y la explicación de que significan , importancia , utilidad etc. De cada archivo que se guarda en dichas carpetas que paso a continuación a detallar

hacia arriba
Significado de iconos


Todo sobre el mod pHoenix

El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Todo sobre el mod pHoenix

Versiones disponibles en el mod pHoenix

En la actualidad podeis encontrar el mod phoenix en [image] emulespaña o en [image] sourceforge ; en la actualidad hay tres versiones del mod phoenix una que incorpora la red kadmelia y otra que no y para los que no anden muy sobrados de recursos o que simplemente no quieran muchas de las opciones que traen ; tanto la que incorpora la red kadmelia como la que no se ha hecho una versión suprimiendo muchas de las opciones ; denominada baby pHoeniX con la versión actual de ; [image] Baby Phoenix 1.5 Alpha 2

la podeis descargar desde [image] aqui

La versión sin la red kadmelia [image] emule 0.30e pHoeniX 1.0 beta 3

Y con las dos redes la ed2k y la red kadmelia [image] eMule 0.42e the pHoeniX 1.4
Como es muy posible que las versiones vayan mas deprisa que el desarrollo de este tutorial no os olvideis de pasar por [image] emulespaña ó [image] sourceforge.

En cualquiera de los dos sitios podeis estar mas al tanto de cualquier novedad en cuanto a posibles actualizaciones , descarga de fuentes etc. Y posiblemente en futuras revisiones de este tutorial no se pongan las ultimas versiones ; ya que lo que verdaderamente importa de este tutorial es la información para el buén funcionamiento del mod y que sepais que en el futuro las posibles actualizaciones del mod pHoenix vendrán con las dos redes incorporadas...; la versión que en la actualidad solo lleva la red ed2k dejará de recibir soporte.

hacia arriba

De lo que se trata ; con la última versión la [image] baby pHoeniX 1.3 alpha 1 ; es de hacer una versión lo mas compacta posible , suprimiendo cualquier caracteristica que no se suela usar.
Sin que por ello deje de ser eficiente ; para eso irá creciendo en estabilidad...

hacia arriba

Y creciendo y creciendo... Pero no por ello va a dejar de ser todo lo eficiente que se puede esperar del mod pHoenix

hacia arriba

Pero tranquilos que ya vereis como os gusta y os convenze la evolución de este mozalbete ; seguro que os dará muchas alegrias

hacia arriba

Páginas contenido de

Todo sobre el mod pHoenix
Carpetas y archivos del mod pHoenix
Significado de iconos

hacia arriba
Significado de iconos


El equipo
Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

El equipo

The pHoenix team

TESTERS

---> 147gta
Betatester oficial ademas de ayudaos tambien en el foro.

--->Mostillo
Otro betatester oficial. Es nuestro conejillo de indias preferido. Tambien ayudara en el foro.

--->Tarod´s Son
Otro betatester oficial. Es aleman, que internacionales
And pHoeniX teAm becomes international!! here is a german member!!

FORO

---> tiberius
Se encargara en mayor parte de ayudaos a todos con vuestras dudas y peticiones en el foro.

---> Lion
Algunos ya lo conocereis, pues es moderador. Otro miembro que os ayudara en el foro.

---->roky

VARIOS

---> Binomio Karmesi
No se como definirlo...miscelaneo??jeje...Abarcará diversas tareas como la recopilacion de
sugerencias y otros...

---> LeNSMaN
Sera nuestro maestro del cvs

CODERS

---> Pichuei
El es grande...programador oficial de pHoeniX, es el jefe.

---> ikAbOt
Ese soy yo...yo bueno...yo aprendo de todos ellos, porque son grandes

Somos the pHoeniX team.

Si tu kieres formar parte de nosotros, no tienes mas que decirloooo!! Siempre es bienvenido
gente que colabore con la causa.

Salario: las gracias de la gente

Horas: Esto es un hobby, asi que...haz lo que puedas


Sistema de creditos usados en el mod pHoenix
Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Sistema de creditos usados en el mod pHoenix

Diferentes sistemas de creditos

Por ikabot :

LOS SITEMAS DE CREDITOS

El sistema de créditos es usado para recompensar a los usuarios que contribuyen con la red por ejemplo al subir archivos a otros clientes. El estricto sistema de colas en emule está basado en el tiempo de espera que un usuario ha pasado en la cola. El sistema de créditos otorga un modificador mayor al tiempo de espera por tomar en consideración las subidas y descargas entre los dos clientes. Cuanto más un usuario suba a un cliente tanto más rápido él tomará ventaja en la cola del cliente. Los modificadores son calculados de la cantidad de datos transferidos de los dos clientes. Los valores usados pueden ser vistos en el diálogo de detalles del cliente. para ver esta información, botón derecho sobre cualquier usuario y elige Ver detalles.

>>>>> OFICIAL <<<<<

Hay dos diferentes modificadores de créditos calculados:
Ratio1 = Subido Total x 2 / Descargado Total
Ratio2 = SQRT(Subido Total + 2)
Ambos ratios son comparados y el valor mas bajo es usado como un modificador.
También existen algunas condiciones limites:
> Subido Total < 1MB => Modificador = 1
> Descargado Total = 0 => Modificador = 10
> El Modificador puede no ser mas bajo que 1 o más alto que 10

Notas:
> Todos los clientes que te suban algo son recompensados por el sistema de créditos. No importa si el cliente soporta el sistema de créditos o no.
> Los clientes no soportados no te garantizarán créditos cuando les subas algo.
> Los créditos no son globales. Ellos se intercambian entre dos clientes específicos.
> Los Créditos se guardan en el archivo clients.met. Un unico user hash es usado para identificar al cliente.
> Tus propios créditos son guardados por el cliente quien te debe el crédito. Esto evita la falsificación de créditos.
> Tus propios créditos no pueden ser mostrados.

>>>>> LOVELACE <<<<<

El sistema de Creditos de Lovelace sigue esta fórmula:

modificador de descarga =100*((1-1/(1+exp((3*{MB uploaded to us}^2-{MB descargados de nosotros}^2)/1000)))^6.6667)

Este sistema de creditos...
empieza:1, max:100, min:0.1, ratio:1:1.5, solo una formula
A diferencia del sistema de creditos oficial, los creditos se evaluan mas en las diferencias y no en las cantidades.
Usando el sistema original obtendrias los mejores valores de creditos poco despues de generar un nuevo userhash. Con este sistema puedes conseguir valores buenos de creditos mas rapido si ya has subido muchos Megas antes.

sistema antiguo: 5up/ 5down = DLModifier of 2, additional 5up = DLModifier of 4
10up/10down = DLModifier of 2, additional 5up = DLModifier of 3
->para la misma cantidad de subida adicional, obtienes menos puntuacion (-25%)

sistema nuevo: 5up/ 5down = DLModifier of 1.16, additional 5up = DLModifier of 2.31
10up/10down = DLModifier of 1.85, additional 5up = DLModifier of 5.09
-> para la misma cantidad de subida adicional, obtienes mas puntuacion (+120%)
porque ya has subido antes una cierta cantidad de megas

MORALEJA: Este sistema de creditos benefician mas a los que mas suben

>>>>> PAWCIO <<<<<

- Rango desde 1.0 hasta 100.0
- Multiplicador de 3 (en vez de 2) ---- ratio = 3 * descargado / subido
- Para nuevos clientes (descargado y subido menos que 1MB) ratio = 3.0 (en vez de 1.0)
- Si has recibido mas de 1MB de alguien pero no le has dado nada...ese usuario obtiene un ratio = 100.0
- Pequeño bonus para aquellos clientes que te han dado muchos megas:
- Si te dan 100Mb, ese usuario obtiene un ratio = 50.0 hasta que le hayas devuelto 108MB
- 50MB - ratio = 25.0 - 55MB
- 25MB - ratio = 12.0 - 28MB
- 10MB - ratio = 5.0 - 12MB

>>>>> NINGUNO <<<<<

Este la verdad que creo que no necesita explicación.

NOTA: Información sacada de unas FAQs de emule traducidas al castellano x linux_rodo y los changelogs de Lovelace y Pawcio


Sobre routers y módems usb
Aclaración sobre distintos conceptos
Diferentes consejos y recomendaciones
Distintas cuestiones sobre los servidores
Un poco de historia
Buscar
Todo sobre el mod pHoenix
Para módem 56K

Sobre routers y módems usb

Routers y módems usb

Todos los enlaces que os voy a poner conducen a la misma [image] Web ; a la cual quiero agradecer desde aquí su espacio y darle las gracias a todos los usuarios que tan desinteresadamente han colaborado para poco a poco ir ayudando y publicando las informaciones y resolviendo dudas que un momento dado cualquier persona pueda tener , hay mas routers y modems y mucho que hablar sobre ellos , problemas , ¿como lo configuro? etc., mas adelante seguramente os iré facilitando mas información.

Routers:

 3com 812 // [image] 3com wireles11g // [image] Alcatel speed touch // [image] Cisco 827 // [image] Comtrend 500 // [image] D-Link 500 // [image] Nokia M1112 // [image] SpeedStream 5660 // [image] Thomson 510 // [image] US Rotics 9003 // [image] Xavi Wireless // [image] Zyxel prestige 643 // [image] Zyxel prestige 650 HW

Módems usb:

US robotics 8500 // [image] Copperjet 800 // [image] 3com usb // [image] Zyxel 630

Sobre routers y módems usb Aquí os dejo algunos enlaces para que podais configurar vuestro router ó módems usb. No están todos , pero se irá ampliando


Un poco de historia
Todo sobre el mod pHoenix
Para módem 56K

Un poco de historia

Un poco de historia nunca viene mal

¿Que es eMule?
En el amanecer del 13 de Mayo de 2002 un chico llamado Merkur no estaba satisfecho con el cliente original eDonkey2000 y estaba convencido de que el lo podía hacer mejor; Y eso hizo. Juntó otros desarrolladores a su alrededor, y el proyecto eMule nació. Su objetivo era colocar el cliente donde el eDonkey había sido famoso antes, añadiendo toneladas de nuevas funcionalidades y un bonito interfaz grafico. No podían imaginar el impacto que esa decisión iba a tener...

A día de hoy, eMule es uno de los mayores y mejores clientes de punto a punto (peer to peer) del mundo. Gracias a su política de código abierto muchos desarrolladores pueden contribuir al proyecto, haciendo la red mejor con cada nueva versión.

¿Que significa eMule?
El nombre "eMule" viene de un animal llamado 'mula' que es similar a un burro (donkey) ;)

¿Cada cuanto se actualiza eMule?
eMule no se actualiza regularmente, pero en este momento la frecuencia es de 1 a 3 semanas. Pero no lo tomes como seguro ;)

Lista de algunas funcionalidades disponibles. Los clientes utilizan varias redes para crear una red única. (ED2K, intercambio de fuentes, Kad) Kad aun está en su versión alpha, con un cliente de pruebas disponible para descargar. El sistema de colas y de créditos de eMule ayuda a asegurar que todo el mundo conseguirá el archivo que quiere dando prioridad a los que suben datos a la red.

eMule es completamente gratuito. eMule tampoco tiene nada de Adware, Spyware, etc. Hacemos esto por diversión y aprendizaje, no por dinero.

Se comprueba que cada archivo esté libre de corrupción mientras se descarga para asegurar un archivo libre de errores.

El sistema de control de corrupción inteligente (ICH) ayuda a acelerar la corrección de las partes corruptas.

Las prioridades automáticas y el control de fuentes te permiten empezar varias descargas sin tener que monitorearlas.

La función de previsualizacion le permite mirar los videos y archivos antes de que estén completados. Para previsualizacion de video, recomendamos el video Lan Client.

eMule dispone de servicios de Web y un servidor de Web para permitirle un rápido acceso desde y hacia Internet.

Puedes crear categorías en tus descargas para organizarlas.

Para encontrar el archivo que buscas, eMule ofrece un amplio rango de posibilidades de búsqueda incluyendo: Servidores (Local, y Global), basados en web (Jigle, y Filedonkey), y Kad (Aun en Alpha (pruebas)).

eMule también te permite utilizar complejas expresiones booleanas que hacen las búsquedas mucho mas flexibles.

Con el sistema de mensajes y amigos, puedes enviar mensajes a otros clientes y añadirlos como amigos. en tu lista de amigos, siempre puedes ver si alguno esta conectado en ese momento.

Con el cliente de irc integrado, puedes hablar con otra gente que este realizando descargas o simplemente hablando con otros clientes del mundo.

¿que es la red kadmelia?

¿que es la red kadmelia? Intentaré aclararlo un poco

La red kademlia no usa servidores , son los propios usuarios los que se conectan entre si sin usar la red ed2k ; igual que hace overnet , los protocolos de esta red los podéis encontrar aqui .

Las ultimas versiones , de momento incorporan las dos opciones , la red kademlia y la red ed2k ; y por el momento es aconsejable conectarse a las dos redes, para lo cual lo podéis hacer en...: preferencias / conexión y aseguraros de que teneis marcadas las dos casillas ( kad ; y ed2k).

El uso de esta red , todabia no está muy extendido por lo cual todabia no se puede comparar a la red ed2k , en numero de usuarios ;

Encendamos la luz Y recordemos un poco de historia