First Topic

X File Format Support

The ID_X plug-in provides support for XBM and XPM formats.

These are unique image formats developed for the X windows environment on Unix/Linux. They are strongly intended for use by software developers for small images such as icons found in user interfaces. Instead of representing an image in some binary format (as normal image formats do), XBM and XPM files are in fact source code for an array in the C programming language. The code has a standard form, though, so that imaging programs can read the data without a C compiler.

XBM files contain 1-bit black & white images; XPM files contain paletted images with an unlimited number of colors. XBM/XPM files are not compressed; in fact, they are substantially larger than typical uncompressed images.