First Topic

PNM File Format Support

PNM formats: PBM, PGM, and PPM

PBM, PGM and PPM stand for Portable BitMap, Portable GreyMap, and Portable PixMap, respectively. PNM stands for Portable AnyMap, and is really an alias for the other three formats.

These are simple file formats popularized by the PBMPlus image toolkit, which converts image files between different formats using PBM/PGM/PPM as an intermediate format.

There is little reason to use these formats, because they are so large: not only is a PNM image uncompressed, but it can be up to 16 times the size of an equivalent uncompressed image in other formats. This is because the image data is encoded as ASCII text.

The PNM series of formats does not support palettes.