First Topic

MrSID File Format Support

MrSID, which is an acronymn for Multi-resolution Seamless Image Database, is an image format developed for browsing extremely large image files. With MrSID, you can browse a file at any magnification level without loading the entire file into memory. The company that owns the format, LizardTech (www.lizardtech.com), sells a series of products for creating and managing MrSID files. The company claims that compression ratios average 20:1 for greyscale and 50:1 for full color images, while maintaining high image quality.