First Topic

FPX File Format Support

The FlashPix (.fpx) file format was developed by Kodak, Microsoft Corporation, Hewlett-Packard Company, and Live Picture Inc. to solve the problems of dealing with large images and large collections of images. It has the following key features:

  • When saving an image at a given resolution, a series of smaller, lower resolution versions of the image are saved with it. This means that, for instance, programs need not load an entire large image file to display a thumbnail.

  • Views are stored in the file which specify transformations to apply to an image. For example, you can have a series of views which display the image with different color adjustments or brightness.

  • Unlimited, structured metadata (non-image data) can be stored with the image.